What are LobbyCentral's supported browsers?

Updated 8/3/15

The following browsers are supported by LobbyCentral cloud and on-premise. Browsers that do not appear in this list are not supported and are considered "use at your own risk".  

Technical support is not available for browsers that do not appear in this list

  • Internet Explorer 10 or higher
  • Microsoft Edge 
  • Google Chrome (PC, Mac, Android, and iOS)

Additional Requirements

  • JavaScript Enabled/Allowed
  • Flash or QuickTime Plug-In to play notification alerts
  • HTML5
Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us