Security update: TLS 1.0 and TLS 1.1 no longer supported

In order to provide the safest and most secure environment for our customers and their data, TLS 1.0 and TLS 1.1, communication protocols used by web browsers, have been DISABLED.

TLS, or Transport Layer Security, is a communication protocol used for network traffic. The early versions 1.0 and 1.1 are vulnerable to hacker exploits.  The infamous "Heartbleed" vulnerability exploited these versions.

All government websites are now required to have servers using TLS 1.2 or higher. The current version of TLS is 1.3.

Following best security practices, LobbyCentral's servers will only accept connections from web browsers that can support TLS 1.2 or 1.3. All other connections will be rejected.

Next Steps

Depending on the web browser your company uses, and its version, you may need to take additional steps to ensure that you can connect to the LobbyCentral server.

The latest version of Microsoft Edge and Google Chrome use TLS 1.3. If you are using an older version of these, or a different web browser, you can check if it will support TLS 1.2 or 1.3 by visiting this website: How's My SSL? ( This page will evaluate and provide information about your browser. Check the Version section to see what TLS version is being used.

If the version displayed is less than 1.2, you must update the browser to the latest version or change to the recommended browser, Microsoft Edge.

Internet Explorer is no longer supported. 

If you have any questions, please contact support at [email protected].

On-Premise customers using LobbyCentral Appointments

The Appointment Broker is an application that is installed on a local server and is used to communicate with LobbyCentral Appointments.  Please download the latest version here.

With the TLS change, the server that the Appointment Broker is installed on must use TLS 1.2 when communicating with LobbyCentral's server.  

Older versions of Windows Server such as 2008 and 2012 do not have TLS 1.2 enabled by default.

Your IT department can determine if TLS 1.2 is installed and enabled.   Please note the following:

  • If the server needs to use TLS 1.0 or 1.1 for other applications, TLS 1.2 should be set as the Default protocol.
  • If the server does not need TLS 1.0 or 1.1, those should be disabled.
Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us