LobbyCentral is supported on the following devices with the following operating system installed:


iPad

  • iOS v9.0 or higher
  • Mobile Safari or Google Chrome

Android
  • Kit Kat or higher
  • Google Chrome